AWS has reported that all services within the us-east-1 region have been fully restored.
Our third-party upstream vendors affected by this outage have implemented their own mitigations and confirmed that their services are stable. Boostlingo systems are fully operational, and we are not observing any active impact on performance.
The Boostlingo Engineering Team will continue elevated monitoring until AWS completes its post-incident recovery and publishes their summary report.
Posted Oct 20, 2025 - 20:26 PDT
Update
AWS has implemented additional mitigations in the us-east-1 region, and overall recovery continues to improve across their core infrastructure.
Our upstream vendors previously affected by the outage have restored their services, and Boostlingo Web services are fully operational. We are not observing any ongoing impact to our systems at this time.
Our Engineering Team will continue to monitor system performance and maintain an elevated watch until AWS confirms full regional recovery.
Posted Oct 20, 2025 - 13:14 PDT
Update
Update: AWS us-east-1 Recovery Progress
AWS is reporting that many core services in the us-east-1 region have been restored.
Our Engineering Team continues to monitor system performance and validate full recovery across impacted third-party services. We will maintain heightened monitoring until AWS confirms all systems are fully operational.
Posted Oct 20, 2025 - 08:37 PDT
Monitoring
As we continue monitoring the AWS us-east-1 outage affecting some of our third-party services, we’re seeing improvement, audio calls are now connecting successfully.
However, due to continued issues with another upstream vendor, there remains a risk of degraded performance within the Boostlingo Web Application. Our Engineering Team is closely monitoring all systems and will provide updates as conditions stabilize.
Posted Oct 20, 2025 - 05:31 PDT
Investigating
This morning, the Boostlingo Engineering Team was alerted to an outage in the Amazon Web Services (AWS) us-east-1 region. While Boostlingo does not host infrastructure in this region, some of our vendors operate within it.
Currently, our telephony vendor Twilio is experiencing service disruptions, which may impact audio calls across the Boostlingo platform. Users may experience degraded audio quality or be unable to initiate new calls.
Our Engineering Team is actively monitoring the situation and assessing any broader impact across our services. Updates will be posted here as new information becomes available.
For more details from AWS, you can track their official status page here: AWS Service Health Dashboard https://tinyurl.com/mwn6umzj
Posted Oct 20, 2025 - 05:18 PDT
This incident affected: Boostlingo Messaging (Boostlingo SMS, Boostlingo EMail API v3), Boostlingo Voice (Boostllingo Voice IVR, Boostlingo Network Traversal Service, Boostlingo Speech Recognition, SIP Proxy), Boostlingo Portal (Boostlingo Interpreter Portal, Boostlingo Requestor Portal), Boostlingo Video (Boostlingo Group Rooms, Boostlingo Communication REST API), and Twilio Voice, North America, Twilio SMS Long Code, North America.